CentOS 5.x 使用的 PHP 版本為 5.1.x,若要使用 PHP 5.2 的
版本,又不想裝 EPEL,以下有個簡單的方式,可以同步升級至
相關的 PHP 套件。


1) 建議先將常用的 php 相關套件先透過 yum install 安裝。

2) 編輯 CentOS-Base.repo,新增一筆更新的項目。

vi /etc/yum.repos.d/CentOS-Base.repo


[c5-testing]
name=CentOS-5 Testing
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing


3) 執行 yum update php-*。

4) 更新完畢後,重新啟動 Apache,輸入「php -v」,確認版本。

5) 接著再將 CentOS-Base.repo ‧ CentOS-5 Testing 改成「enabled=0」。


                          Paul

paul 發表在 痞客邦 PIXNET 留言(0) 人氣()